SAP Knowledge Base Article - Public

2965183 - E-Mail Activity Created Via Workflow Rule Does Not Display Message Text

Symptom

E-Mail sent via a workflow rule is no longer displaying the interaction text in the E-Mail activity.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: You have created a workflow rule that sents out an E-Mail.

  1. Go to the Activities work center.
  2. Go to the E-Mails view.
  3. Search and open E-mail activity XXX (XXX represents the E-Mail Activity ID).
  4. In the Overview facet, the Message text box does not display any content.

Cause

With the 2008 release, there was a change made to the way the content of E-Mail created via workflow rules is stored.

Previously the content of these type of E-Mails was stored on the text collection node of the E-Mail activity and the content could be seen in the Message Text.

This had some limitations as for example you could not view the final E-Mail in a rich text format and the HTML was actually displayed.

Resolution

The E-Mail content is now stored in Attachment Folder of the Email Activity.

This can now be viewed from the facet "E-Mail Viewer" in the E-mail TI.

See Also

E-Mail, E-Mail Activity, Activity, Workflow Rule, Message, Interaction, Outbound, Sales Order

Keywords

KBA , e-mail , e-mail activity , workflow rule , message , LOD-CRM-ACT , Activities , Product Enhancement

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2008