SAP Knowledge Base Article - Public

2965183 - E-Mail Activity Created Via Workflow Rule Does Not Display Message Text

Symptom

The email sent through a workflow rule is not displaying the interaction text in the email activity.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: You have created a workflow rule that sents out an E-Mail.

  1. Go to the Activities work center.
  2. Go to the E-Mails view.
  3. Search and open E-mail activity XXX (XXX represents the E-Mail Activity ID).
  4. In the Overview facet, the Message text box does not display any content.

Cause

The template body contains html content (in table format) and while displaying the email body in the Message" field, we remove the html tags.

This is the current behavior for the Overview screen. Currently, the Message field only shows plain text format of the email body.

Resolution

The full details of the email can be seen via a different tab called "E-mail Viewer" and you can add it via Adaptation Mode within the Email Activity Object.

Keywords

E-Mail;E-Mail Activity; Activity; Workflow Rule; Message; Interaction; Outbound; Sales Order; , KBA , e-mail , e-mail activity , workflow rule , message , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer add-ins all versions