SAP Knowledge Base Article - Public

2965763 - Multiple Errors for PrintQueueWebService3 Web Service Interface

Symptom

You have observed multiple errors for interface PrintQueueWebService3 in the Web Service Message Monitoring work center view.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Business By Design
  • SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Web Service Message Monitoring work center view
    • In SAP Business ByDesign, this is within the Application and User Management work center
    • In SAP Cloud for Customer, this is within the Administartor work center
  2. Here you see many of the errors as shown in the screenshot below:

error.png

Cause

If you are using a PDI (partner developed) solution, SAP provides an API which does not send a response.Due to this, the documents are successfully printed, but the status does not change to Successful nor you see the output medium, such is the name of the printer etc.

Print Queue status with a partner solution:

Printerqueue Status with PDI.png

Print Queue status with SAP's standard solution:

Printerqueuestatusstandard.png

Resolution

Please ignore these messages.

Correcting this requires huge coding change on SAP's part, which will provided in one of the products' future releases.

Keywords

Webservice, Printer queue Error, Web Service Monitoring, PrintQueueWebService3 , KBA , printqueuewebservice3 , webservice , error printqueuewebservice3 , printer queue error , web service monitoring , AP-RC-OUT , Output Management , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions