Symptom
Business Rules conditions are not triggered for certain values after you have uploaded via excel or you see that a dump is thrown when determining the rules at runtime.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have configured a Business Rules condition (for example, Ticket Routing Rules) based on the value of a certain field (for example, post code).
These rules were uploaded via excel file in Administrator Work Center > Service and Social > Ticket Routing Rules by Employee
During normal business activities, the conditions should be triggered.
Cause
The decision table (in the back end) only allows for a maximum of 99 results per cell.
For example, if you upload an excel file with > 99 values in a single cell, the Business Rules Framework (BRF) will only be able to store / generate runtime code for the first 99 values.
Resolution
You would need to limit the size to < 99 values. Instead of maintaining > 99 values in a single cell, you can split the condition into more rows, each containing < 99 values.
Keywords
BRF, PDI, rule, decision table, maximum values, excel upload , KBA , LOD-CRM-BRF , C4C BRF Configuration , Known Error