Symptom
You create a new extension field of type "Time", on field definition the default value is set as empty, however for new instances the field is filled with "00:00".
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to New Ticket. Also applicable for other business objects.
- On adaptation mode.
- Click on Add Field.
- Create a new extension field of type Time.
- Let default value empty.
- Add field to UI.
- Leave adaptation mode.
- Create a new ticket.
- Time field created is filled with 00:00.
Cause
This is expected behavior as per the system design.
Resolution
New instances will be filled with "00:00" once default value is empty on field definition.
Keywords
Time field, default value. , KBA , AP-RC-UIF , C4C UI Framework , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions