Symptom
It is not possible to edit a standard element field that contains personal information as it is grayed out, despite of "Edit" permission being granted.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Profile
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Employee Profile;
- Try to edit a standard element, such as "First Name" and see that even having "Edit" permission, the field it grayed out and you can not edit it;
- Now check in Configure People Profile and see that the block is properly created;
- The same in BCUI, the field is properly created and permissioned;
Cause
In instances that have Employee Central - EC enabled, the value of an Standard Element field (which in the provided example is the "First Name") will cointain the same information as EC's "Personal Information" HRIS Element (in the provided example: "personalInfo").
Resolution
In order to be able to edit the personal information you must edit the EC's HRIS Element field value, instead of the standard element value.
And once you do, it will automatically be synced to EP's Standard Element field, as below:
- Edit employee's first name in Personal Information block;
- Confirm the request and engage the responsible personel to approve the workflow;
- With that done, the new value will reflect in EC and EP's fields.
See Also
2654767 - EP Destination Fields Still Editable via UI for EC Users
Keywords
personal info, personal information, HRIS element, standard element, grayed out, field, value, edit, permission, granted, assigned, provided, configure people profile, approve, workflow, manage business configuration, BCUI. , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-EC , Employee Central , LOD-SF-EP-UI , People Profile UI (PP3 UI) , Problem