Symptom
You have set the delivery priority under the Account as immediate, however, when creating a Service Order for the expected Account, the Customer Demand is not created automatically for Spare Parts items.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Select the Service Order Processing view.
- Click New.
- Select Service Order.
- Enter the Account ID ABC (ABC represents the ID of the Account which contains the delivery priority as Immediate in the master data).
- Enter a Spare Part item.
- Click Release.
When navigating to the Document Flow tab, you don't see the Customer Demand.
Cause
The delivery priority maintained in the Account master data is not carried to the Service Order.
Resolution
This is the system expected behavior.
When issuing a Service Order which requires the creation of the Customer Demand immediately, please change the value during the creation of the document under the General tab.
If you believe that this feature could be enhanced, please create a thread under the SAP Customer Influence Platform to submit an idea: https://influence.sap.com/SAPByDesign
Keywords
Service Order, Spare Parts, Delivery, Priority, Immediate, Normal , KBA , AP-SVO , Service Order Processing , How To