SAP Knowledge Base Article - Public

2969333 - New Product Added in Saved Draft Version of An Existing Survey Cannot Be Deleted

Symptom

New products can be added in an existing survey of a Visit, which has an option to delete new products added. However, if the draft version of survey is saved within the visit, delete option for new product is missing.

Environment

SAP Cloud For Customer

Reproducing the Issue

Prerequisite. Task created has an existing active survey added.

  1. Log into Fiori.
  2. Go to Visits Work Center.
  3. Search and open Visit XXX, where XXX represents Visit's ID.
  4. Go to the Survey Facet.
  5. Select and open already added survey.
  6. Click on "Add product" option.
  7. Choose "All product".
  8. Window with list of products can be seen.
  9. Select/check rows of new products that are to be added in an existing survey.
  10. Newly added products show, X icon, which allow deletion of added product in the survey.
  11. Click on "Save as Draft".
  12. Once survey is saved as draft, option for deletion of newly added product does not exists.

Cause

Product added in in saved draft version of an existing survey, are used in Visits for various scenarios, for example Perfect Store KPI Calculations.

This is the reason towards nonexistence of delete option for product added and saved, in draft version of an existing survey.

Resolution

New product added in saved draft version of an existing survey cannot Be deleted. This is an expected behavior.

Keywords

New Products, Saved Draft Version, Survey, Visits, Delete product , KBA , unable , delete, products, draft survey , LOD-LE-SUR , Survey , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions