Symptom
In the Adaptation mode in Advanced Search for Account, it does not provide an option to add "Territory" or "Employee" field.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Cloud For Customer
Reproducing the Issue
- Navigate to Customers WC
- Go to Accounts WC View.
- Enter the Adaptation Mode.
- Click on Advanced Filter icon.
- Select search query option "My Accounts".
- Click on Pencil icon.
- Expand Team section in Adaptation Mode.
- Set the Employee or Territory field as Personalize and Visible.
- The field is not added to the UI.
Cause
The Territory and Employee field in "Team" section of Advanced Search does not exist in selected search query "My Accounts".
These fields only exist in Adaptation mode if the query selected in Advanced Search is "All".
Resolution
In Adaptation mode, select the account search query "All" in Advance Search, which allows the option to add Territory field and Employee field in "Team" section.
Please note that even if the field is added in the "All" query, it will not be visible in the "My Accounts" query.
Keywords
Adaptation Mode, Territory Field, Employee Field, Add, Advance Filter, Account Query, All, My accounts , KBA , territory, employee, query, all , adaptation, account, advance filter , LOD-CRM-ACC , Account , Problem