SAP Knowledge Base Article - Public

2970380 - Missing date field under Date Filter tab - Tile

Symptom

When building a tile, under “Date Filters” tab you are missing some date fields in “Apply Date Filter To”.

Environment

  • SAP SuccessFactors HXM Suite
  • Tile
  • Dashboard

Reproducing the Issue

  1. Edit any tile;
  2. In “Date Filters” tab, check “Enable Date Filter” box;
  3. In “Apply Date Filter To” option realize that there is missing some fields storing date records.

Cause

The cause that these fields are missing in “Apply Date Filter To” is due to the fields are not set as date field. The “Apply Date Filter To” option only shows up the fields strictly set as date.
NOTE that sometimes date records can be stored in either string or timestamp fields which are not date fields.

Resolution

The “Apply Date Filter To” feature is working as designed. This feature will only show up the fields set as date fields.

See Also

2838315 - Date Filters in Dashboard tiles not set in the filter section ( Mandatory Prompts )
2273496 - How to Create and Use the Date Range filters in Tiles for Dashboard

Keywords

Tile; Dashboard; Missing; Date; Filter; Tab; Apply; Record; String; Timestamp; Edit; Create; , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , Problem

Product

SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors HCM suite all versions