SAP Knowledge Base Article - Public

2971255 - Position to Job Sync via Job History fields are not populated correctly - Employee Central

Symptom

When selecting a new position from employee job information history, the fields are not populated correctly, however from Take Action this is working accordingly.


Note: This KBA is only relevant if you use Position to Job Sync rule to set "company" field.

Environment

  • SAP SuccessFactors Employee Central
  • Position Management

Reproducing the Issue

  1. Go to Job History
  2. Select Edit or Insert a New Record
  3. Select a position that belongs another company


Result: Organization fields is not getting populated based on the new position selection. Just if the position is selected twice.

Cause

This is currently expected behavior by the system as job history has different logic than take action when the company field is refreshed by the position to job rule.


Resolution

If this behavior is needed to change this behavior please feel free to open a new enhancement request to get same behavior from Job History as Take Action:


Following KBA explains how to submit a new enhancement idea:

2090228 - How to Submit Ideas for SAP SuccessFactors Products


Note: Please note that this behavior can be avoided using the "Use Company Filter for Positions in MSS Job Information and History" under Position Management Settings and not using the Position to Job Sync rule to select company, this way system will filter the job information positions based on the company selection instead.

Keywords

postojob, position, to, job, sync, pos2job, job, history, blank, fields, populate, propagation, not,working, take, action, selection,  , KBA , LOD-SF-EC-POS-PTJ , Position to Job Information Sync , LOD-SF-EC-POS , Position Management , Product Enhancement

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite 1911