Symptom
Payment Information Not Displayed While Adding New Employee.
Environment
SAP SuccessFactors Employee Central - Payment Information
Reproducing the Issue
- Log into your SF instance.
- Navigate to the "Add New Employee" page.
- Fill out all the sections up to the Compensation Information section.
- Notice that the "Payment Information" section is missing on the final step.
Cause
Restricted Personal Information Lookup in Object Definitions Configuration.
Resolution
If this permission is required, follow these steps to grant access:
- Go to "Manage Permission Roles."
- Select the desired permission role.
- Grant access to the "Personal Information Screen Lookup."
If this restriction is not needed, follow these steps:
- Go to "Configure Object Definitions."
- Search for the object "Personal Information Screen Lookup."
- Under "Take Action," select "Make Correction."
- On the Security tab, set "Secured" to "No."
Keywords
permission, payment information, add new employee, add new hire wizard, Personal Information Screen Lookup, secured, missing, visibility, configure object definition , KBA , LOD-SF-EC-HIR-NEW , Add New Employee Wizard , Problem
Product
SAP SuccessFactors Employee Central 2411