SAP Knowledge Base Article - Public

2972422 - Error: "Record for entity user with key user/userid=**** does not exist" in Latest Version of Continuous Performance Management

Symptom

There is a pop-up error "Record for entity user with key user/userid=**** does not exist. Please check the key value" when an Employee or Manager accesses Continuous Performance Management.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Continuous Performance Management

Reproducing the Issue

  1. The latest version of Continuous Performance Management has been enabled
  2. As an Employee or Manager, go to Admin Center > Home dropdown > Continuous Performance Management.

The following pop-up error occurs, and the view of Direct Reports is not visible to Managers:

Key user cpm error.png

Cause

This error is caused when a required role-based permission has not been granted to the logged in user.

Resolution

  • The Employee/Manager is missing the "User Search" role-based permission which is required for Continuous Performance Management. (Note: The User Search permission can be restricted to the target population defined for the permission role in which it is included.)
  • Go to Admin Center > Manage Permission Roles > General User Permission > Company Info > enable "User Search":

user search rbp.png

See Also

CPM Admin Guide: Role-based Permissions in Continuous Performance Management

Keywords

CPM, Continuous, Performance, Management, UXR, latest version, Error, problem, permission, pop up, Record, user, value, entity,  id, does not, exist, Record for entity user with key user/userid does not exist. Please check the key value, employee, manager, view, direct report, , KBA , LOD-SF-CPM , Continuous Performance Management , Problem

Product

SAP SuccessFactors Performance & Goals all versions