SAP Knowledge Base Article - Public

2972537 - Error: Business category does not exist; use 1 or 2" but the "Category

Symptom

You received the error: Business category does not exist; use 1 or 2" but the "Category; when creating New Account/Prospect

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center
  2. Select Accounts / Prospects view
  3. Select the Add button (+)

Cause

The business role assigned to the user has business field CUST_CATEGORY is set to read only.

This is the reason why the default value 2 (organisation) is not assigned opening the account Quick Create (QC) view.

Resolution

Follow the below steps to remove the business field restriction from the business role.

  1. Go to the Administrator work center
  2. Select the Business Role view
  3. Select the Administrator Business Role
  4. Select the tab Fields & Actions

Keywords

Business Category , KBA , LOD-LE-BP-BP , Business Partner , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions