Symptom
- When user goes to Process Variant manager, there is no Default Process variant created once ONB 2.0 switch is enabled.
- Unable to see the BPE admin pages like BPE monitor Process, BPE Process definition etc
Environment
Successfactors Onboarding 2.0
Reproducing the Issue
- Login to Instance and search for Process variant manager
- Verify if you can see Default Process Variant
Cause
- BPE process definition was not deployed in instance.
- BPE admin permission was enabled
Resolution
If default process variant is not enabled follow below step.
- Go to Update process flow for Onboarding 2.0 and Offboarding 2.0 and select the Service user and make sure process is deployed successfully.
Once this is completed Default Process variant will appear in PVM page.
If you still can not see the default process variant, you can manually deploy the BPE process by following below step.
- Go to BPE: Manage Process Definitions, Download the the XML for Onboarding2ProcessCoreWorkflow.bpmn20.
- Then go to BPE:Deploy Process Definition and you can Import the downloaded XML back.
Incase if you do not see Update process flow for Onboarding 2.0 and Offboarding 2.0 page from admin center/Search window, then make sure below permission is enabled in RBP role affected user is part of.
If you do not see Service user not appearing from Update process flow for Onboarding 2.0 and Offboarding 2.0 page, then refer below link from admin guide to set up the Service User.
Keywords
Default Process variant, Service user. BPE manage process, Update Process flow , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem