Symptom
When updating a position via Position Org Chart or Manage Position, system encounters a Gateway Timeout error
Environment
SAP SuccessFactors Employee Central - Position Management
Reproducing the Issue
- Make any change to position via Position Org Chart or Manage Positions
- Select "Yes" when message for synchronizing position changes to incumbent/s prompts
- System loads and shows "Gateway Timeout" error
Cause
Position given is having unexpectedly large number of incumbents. When saving position it triggers Position to Job Information sync which in turn triggers job information onSave rules.
Resolution
Update position using imports instead so this will be executed as a job.
Engineering team has no plans of enhancing this yet hence you may raise this as an Enhancement Ticket.
See Also
Keywords
Gateway Timeout Error, position change, position sync, position org chart, manage positions, INC0062371 , KBA , LOD-SF-EC-POS-ORG , Position Org Chart UI & Manage Positions , Problem