Symptom
- You are unable to assign users to any business role. When selecting any business role and assigning it to the user, an error occurred. Error: Assigned business role INV_SOL_GW_END_USER does not exist.
- You observed that you cannot see the business role INV_SOL_GW_END_USER in the UI. It looks like that it is assigned to the user in the backend.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator work center
- Click on Business Users view
- Search for the relevant business user
- Click on the three dots
- Click on Update Access Rights
- Click on Update All Users
- Click on Confirm
- Click on Show Background Runs for All Users
- Click on Display Logs
- Click on Results
Cause
The reported business role INV_SOL_GW_END_USER has been deleted in the system from the backend. Since the deletion is not allowed when the role is assigned to any user, it has been recreated in the system by a background job. Even if it has been recreated, it is not showing as expected in the UI.
Resolution
Please open an case and approve backend correction.
Keywords
Business role, seever-side integration, Outlook integration, INV_SOL_GW_END_USER, , KBA , LOD-CRM-INT-OEM , Provisioning issues for OEM integration (eg iCRM) , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions