SAP Knowledge Base Article - Public

2976824 - Custom Card Not Displaying Video Embed Code

Symptom

  • Video is missing from Custom Card when I'm saving changes;
  • Custom Card is not showing the video;

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. You created or edited a custom card under Manage Home Page;
  2. On Insert/Edit Media, you place a URL and codes;
  3. When you are saving the changes, details from video is being missed

Cause

feature is enabled in this environment and that is why you are facing this behavior.

Resolution

You can temporarily disable Sanitize all rich text inputs feature:

  1. Admin Center > Company Settings > Company System & Logo Settings;
  2. Uncheck Sanitize all rich text inputs option > Save.
  3. On Custom Card in question, add the information from the video > Save;
  4. You can enable Sanitize all rich text inputs option again if you would like;

For additional information about Sanitize all rich text inputs option, you may follow the KBA 2076569 - Manage Live Forms - Sanitize Rich Text Inputs to Remove Bad Characters - Performance Management

See Also

2642447 - Inserting image and video on Custom Cards content - SAP for Me

3033503 - Latest Home Page Custom Card Limitations - SAP for Me

Keywords

videos error, failing to save, custom cards, Insert/Edit Media. , KBA , LOD-SF-PLT-TIL , Custom Tile/Card Issues , How To

Product

SAP SuccessFactors HCM suite all versions

Attachments

Pasted image.png