SAP Knowledge Base Article - Public

2977081 - Access Restrictions For BPM Accounts Not Working

Symptom

You have created two users and two customers. But both users have access to both customers, even though you have restricted the access for both users and you have scoped the question Do you want to restrict access to content in account overview? in Business Configuration work center > Implementation Projects view > Edit Project Scope > 4 Questions > General Business Data > Business Partners > Handling of Business Partners.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Log in with user
  2. Go to Account Management work center
  3. Click on Accounts view
  4. Select All Accounts
  5. Search for the account

Cause

Employees can be assigned to accounts for which they are directly responsible. This assignment is used as a basis for defining access restrictions for viewing and editing accounts. After you have defined access restrictions for an account in the Business Users view, a user can only view or edit the account if the employee directly responsible for that account has also been assigned to that user with the appropriate read or write access.

Resolution

You need to add a direct responsibility to the account so that the access restrictions for viewing and editing accounts can be applied.

Keywords

Berechtigungseinschränkungen, Kundenstamm trennen, Zugriff auf alle Kundenstammdaten, access restricitions, customer master data, access restrictions not working, BPM accounts, , KBA , SRD-CRM-ACC , Account Management , Problem

Product

SAP Business ByDesign all versions