Symptom
External Candidates are being able to create accounts with different locales than the ones enabled for Recruiting.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Suppose customer has enabled only English US for Recruiting language.
- It means external career site will have only en_US for locale. In language drop down also we can see only English US
- Now suppose candidate put the external career site url like this https://career5.successfactors.eu/career?career_company=AEW&lang=en_UK
- Here candidate forcefully passing English UK as language.
- We can notice the external career site language drop down also changing to English UK though it is not enabled in RCM languages.
- Now when candidate creates the profile the language for this candidate will be en_UK.
Cause
Candidates were able to change the URL and add a different locale by the end of it, therefore forcing the system the pick the locale chosen.
Resolution
Product Support and Software Engineering team are acknowledged of this scenario and a prevent action will be deployed within b2011 release, which will create a validation to check if the entered locale is enable or not, therefore if not, the system won't let the candidate to proceed.
Please notice that it's not possible to determinate how the locale was entered by an existing account.
If by any chance, you face this scenario or a similar one, please submit a ticket to Product Support team referring this KBA Number as well.
Keywords
locale, candidate, invalid, not, incorrect, language, RCM-84189 , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem