Symptom
Use Cost Center inbound API (SAP_COM_0179) to create Cost Center master data. However, the creation is not successful.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Use Cost Center inbound API (SAP_COM_0179) to create Cost Center master data via Postman or SOAP UI.
Cause
See Resolution part.
Resolution
There could be multiple problems when making the update. List below some of them:
1. If below error occurs, it means the head data for your payload is with problem:
<faultcode>soap-env:VersionMismatch</faultcode> |
Solution: Please modify the Sample Payload in the help portal according to your data and use it as the payload. Search keyword: "Sample Payload", and expand it.
2. If return code is 202 without any other response information, and if the cost center is not updated successfully, the issue could happen on the master data side.
Solution: Refer to the steps in the help portal - "Message Monitoring and Error Handling". Check what error happened behind with above information.
Also try to assign all types of messages to the user with app Assign Recipients to Users.
3. With problem 2, although settings were made according to the help portal, below error may occur:
"Error:Error while creating confirmation message: Error (id=):"
Solution: This happens due to incorrect settings App Communication Arrangements. To solve this, edit the Communication Arrangement (SAP_COM_0179) -> Cost Centre Inbound Confirmation - Read. Tick on the flag "Service Status". Then repost the API and check the error log according to solution for question 2 (above). Need to adjust the payload according to the real error messages.
4. If use SOAP UI tool to post the API, the same error as in problem 1 may occur.
Solution: Also refer to KBA 2694433 to make the correct settings.
5. Payload format issues, for example, date and time format.
Solution: Check KBA 2762970 to understand how to find the correct format for a field.
6. If the cost center is already in the system, and it is required to extend the validity period. Find the API didn't create a new validity period.
Solution: it's correct system behavior. The system combines the original validity period with the new validity period. If it is required to see 2 separeate validity periods, need to at least update a fields to a new value for the new validity period.
Keywords
/FINAC, FINAC_RECT_CCTR_IN, Assign Recipients to Users, Message Dashboard, SOAP UI, WSDL, Reliable messaging (RM), postman, outbound, asynchronous. , KBA , CO-OM-CCA-A-2CL , Master Data (Public Cloud) , CO-FIO , Fiori UI for Overhead Cost Controlling , Problem