Symptom
- In the Instance Refresh Tool, a Production instance was chosen as the target, resulting in a validation failure.
- To verify the tooltip message in the status column, click on the question mark icon. The tooltip will display the following message: "Instance Refresh is not supported for a target as a productive tenant."
- The error "TENANTREFRESH_VALIDATION_FAILED_FOR_LIVE_PRODUCTIVE_INSTANCE" is found in the IRT logs.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
After an Instance Refresh Request | SAP Help Portal, the customer will receive a "Validation Failed" status. Upon downloading the Error Log File | SAP Help Portal, the following error code will be displayed: "TENANTREFRESH_VALIDATION_FAILED_FOR_LIVE_PRODUCTIVE_INSTANCE"
Cause
As part of the B2011 release, a guardrail was implemented to prevent refreshes to a productive target instance. Consequently, if a productive instance is selected as the target, the system will return a validation failed error.
As outlined in this KBA 2791468 - Instance Refresh Tool for BizX & LMS | Must-Know Guide & FAQ - SAP for Me under LIMITATIONS,
"Refreshes to Production type tenants are blocked using the tool. Proceeding will result in "Validation Failed" status. See 2978845 for further details. Note: Non-Production tenants hosted in Production server stacks do not fall under this limitation and can be refreshed using the tool."
Resolution
Important Notes:
- In case you receive the error log "TENANTREFRESH_VALIDATION_FAILED_FOR_LIVE_PRODUCTIVE_INSTANCE" after submitting a refresh, this means that your TARGET is tagged as a productive tenant.
- Instances in Production Data centers are not automatically flagged as a "Productive" tenant. Productive tenants are those assigned only with "Tenant Business Type" = ZH421 or ZH422.
- If it's required to refresh your Production instance, it is necessary to follow the Manual Refresh process. Please refer to KBA 2277508 - SuccessFactors Cloud Manual Instance Refresh Process & FAQ for detailed instructions on how to submit a manual refresh request, taking into account the following points:
- Please open the support ticket under "LOD-SF-PLT-REF" to request the manual refresh
- Include the manual refresh request form, filled out and signed. You can find the request form attached to KBA 2277508 - SuccessFactors Cloud Manual Instance Refresh Process & FAQ
- Please ensure to provide a "business justification" as to why a Productive refresh is needed. This is mandatory to request a manual refresh.
Notes for CSMs/CEEs/Support: To view the tenant business type, please check the tenant details from the Cloud Reporting tool.
Note: The tenant type cannot be changed this is necessary for customer license calculation and contract agreements with SAP also maintenance notifications and alerts.
Refreshing the Target Production Instance During Implementation - Please note that starting with the 2505 SuccessFactors release, customers can now refresh their live production tenant during the implementation phase using the Instance Refresh Tool (IRT) with necessary approvals from the administrator. Kindly visit this KBA 3610506 - Approve Production Tenant Refresh Request Enablement Request - SAP for Me
See Also
- 2791468 - Instance Refresh Tool for BizX & LMS | Must-know guide & FAQ
- 2793706 - Product Support Process - Instance Refresh Tool Enablement
- 2277508 - SuccessFactors Cloud Manual Instance Refresh Process & FAQ
- 3610506 - Approve Production Tenant Refresh Request Enablement Request - SAP for Me
- Instance Refresh Overview | SAP Help Portal
Keywords
TLS-13302 , IRT, Source, Target, Productive Tenant, Validation Failed, TENANTREFRESH_VALIDATION_FAILED_FOR_LIVE_PRODUCTIVE_INSTANCE, , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , LOD-SF-PLT-REF , Instance Refresh , Problem