Symptom
When reporting on top of History data sources, such as Ticket History or Opportunity History, you observe that the field End Date brings incorrect values for some entries, like 29/12/9999.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Business Analytics work center.
- Go to the Design Data Sources view.
- Find and open the relevant Data Source in Preview mode.
- Add the fields Ticket, End Date, and Status into the report results.
- Some entries are displaying indefinite date for the field End Date, like 29/12/9999.
Cause
Such values are displayed for the current status of each Ticket / Opportunity, since the End Date cannot predict when the current status will be changed next. Therefore, the system by default brings a date which represents an indefinite period, like 29/12/9999.
Resolution
This is the system expected behavior.
Keywords
Ticket History; End Date; Opportunity History; Wrong End Date , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-SRP , Service Request Processing , How To