SAP Knowledge Base Article - Public

2978883 - Auto Data Purge to Purge Attachments & Person/Non-Person Related Audit Data

Symptom

While trying to download/view an attachment in the instance the following error is seen:

"The document you are trying to access has been removed from the system."

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM Suite

Cause

  • With release b2105, customers can find the Auto Data Purge tab in both Production and Preview instances under the Data Retention Management page to Purge Attachments and Person/Non-Person related audit data. 
  • As per system design, customers have the ability to opt-in/out of feature using Auto Data Purge Tab by checking the available options and maintaining days as Retention Period for auto purging of data.
  • To avoid any impact on current application page logic file details such as file name, file type and extension will remain the same and only attachment content and file size will be updated in attach_content table as blank.
  • Please check the impacts of Auto Data Purge and Retention Periods section of the Admin Guide for different types of data in the instance.

Note: The policy will be enforced only in Preview Instances after getting customer consent via option to opt-out/in policies under Auto data Purge Tab in Data Retention Management.

Resolution

To find the root cause of error "The document you are trying to access has been removed from the system", check feature if opt-in/out and retention period maintained under Data Retention Management > Auto Data Purge tab. 

To opt-in/out of Auto Data Purge policy:

  1. Go to Admin Center > Data Retention Management 
  2. Choose the Auto Data Purge tab as below
  3. Opt-in/out of Auto Purge policy for Purging Attachments and Person/Non-Person related audit data maintaining retention period in days for each
  4. Save

As part of the 2H 2021 release, we have updated the default configuration of Auto Data Purge in Test and Development instances.

More information on the default configurations depending on the tenant types can be found in this section of the admin guide.

In production, test, development, and sales demo instances, all data types aren't selected to be purged by default.

In preview instances, default configurations are different for data types:

  • Documents are selected by default. You can configure the retention period or choose not to purge this data type.
  • Audit Data Containing Personally Identifiable Information isn't selected by default.
  • Audit Data Without Personally Identifiable Information is selected to be purged. You can't make your own configuration of this data type.


FAQ (Frequently Asked Questions)

Q: This feature once enabled, will purge the documents after the defined period for only Inactive users or also for Active Users? Do we have to specify this somewhere? or by default the system will consider all the inactive users? 

A: The Auto Data Purge will purge documents for all users based on the configured retention period, it doesn’t check if the user is active or inactive. If the customer disables Auto Data Purge, then no documents (for either active or inactive users) will be purged. 


Q: If purging of documents are to be done only for inactive users, then what other options do we have?

A: For documents not covered by Auto Data Purge, the customer can use Data Retention Management. 

Modules such as Purge MDF Attachments or DRTM Onboarding Purge allow the customer to purge documents specifically for inactive users, as customer can manually select inactive users or upload a list of inactive users.

Purge MDF Attachments:

DRTM Onboarding Purge:


Q: If you uncheck the 3rd option in Data Retention  Management > Auto Data Purge > “Attachment (minimum retention period:  (0) days)”  - will the attachments always be stored in the system?

A: Yes, if the customer unchecks the option, then nothing will be purged by the auto data purge. But the base storage limit per instance which is set in Document Management still applies.

Q: We cannot manually trigger auto data purging backend job?

A: No, it’s an automated system job managed at the data center level, Individual tenants cannot manually trigger it.

Q: What is the frequency of the auto data purging backend job?

A: Customers can check the last auto data purge job completion date from the Auto Data Purge UI.
Please refer to the attached screenshot for reference.

  • For Documents: The Auto Data Purging job runs every 4 weeks on Saturday.
  • For Audit Data Containing Personally Identifiable Information & Audit Data Without Personally Identifiable InformationThe Auto Data Purging job runs every 4 weeks on Sunday.

Q: Any auto date samples or references for the job req system process status? How to review the different behavior of auto data purge before and after result?

A: Currently, there is no such feature available. However, customers may submit a feature enhancement request by following the steps in KBA: 2090228 - How to submit enhancement ideas for SAP SuccessFactors Products - SAP for Me.

Our PM team will review the request, and we may consider implementing a feature to display how much data was purged during each job run in the future.


Q: Why "Auto Data Purge" UI shows "No purge plan is implemented". 

A: If Auto Data Purge is enabled but the UI shows "no purge plan is implemented", it simply means the customer has only recently enabled the feature and there’s no execution history yet. The system will automatically trigger the next purge job when its scheduled cycle arrives. 


Q: Which job in the Provisioning is run for Auto Data Purge?

A: The Job type is "Data Governance Framework — Company-Level Purge Job”.

You may notice it runs daily, but this is because the same job type is also used to purge other redundant system data such as email delivery status data.


Q: What is the max number of days they can set as the retention period?

A: There is a limit of 1800 days.


Q: In the help guide, there is a "Retention Period" in days for a number of different modules and tools. Which takes precedent, the number of days set in the help guide or the number manually entered in Data Retention Management?

A: Mandatory retention periods are set by module teams to grantee that the system runs smoothly. The actual retention period implemented in the purge process is the longer one between the custom retention period you configured and mandatory retention periods listed in the help guide.


Q: How is the tool able to identify which data to purge? What date is being used as reference for attachments, non-person and person related data?

A: For attachments, this is based on the document creation date. For Audits, some of the tables are based on creation date, some of the tables are based on last modified date.


Q: Will auto data purged attachments be still visible under "Manage Documents" page?

A: Yes, they will appear in Manage Documents page, however,  as the attachments are replaced by dummy attachments, the document size also changes. Lastly, when "purged" attachments are downloaded by administrator, from Manage Documents, they will see the following note below.

Attachment files are replaced by a file named removed when they exceed the set retention periods. The file contains a reminder: "The document that you’re trying to access has been removed from the system."


Q: Will auto data purged attachments be still visible on the module page where it was uploaded?

A: Yes. Links to purged attachments will still be visible in module pages where it was uploaded, however, when downloaded by admins, they will see the message below.

Attachment files are replaced by a file named removed when they exceed the set retention periods. The file contains a reminder: "The document that you’re trying to access has been removed from the system."


Q: How can administrators identify when the last purge was done?

A: Under "Auto Data Purge" tab will show details on when the last purge was completed.


Q: I am using 3rd party storage solutions (Box or OpenText). Will I be affected by the auto purge of attachments?

A: No. This is only applicable for customers utilizing SuccessFactors document storage - "Manage Documents" page from Admin center.

See Also

Keywords

SF, success factors, SuccessFactors, PLT, platform, Biz X, bizx, object, KBA, Data Retention Management, LOD-SF-PLT , LOD-SF-PLT-DRM, Platform Foundational Capabilities, Auto Data Purge, LOD-SF-MDF, LOD-SF-PLT-DOC, attachments empty, dummy file, auto purge, non person related , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors HCM Suite 2511