Symptom
The Integration with SuccessFactors has been scoped in Business Configuration and now you want to descope the setting "Integration of Employee Data From External Application to Cloud Solution". However, an error message is displayed when trying to confirm the changes:
Error During Finish Project
Currently unable to finalize these scope changes; some of your decisions would cause inconsistencies in your fine-tuning settings or the productive data.
If error messages are displayed, resolve then before you proceed.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Configuration Work Center.
- Go to Implementation Projects view.
- Select a change project and click Edit Project Scope.
- Go to step 3. Scoping.
- Expand Human Resources > Personnel Administration.
- Uncheck the scoping element Integration of Employee Data from External Application to Cloud Solution.
- Go to step 4. Questions.
- Expand Communication and Information Exchange > Integration with External Applications and Solutions > Integration Scenarios for Cloud Solutions from SAP.
- Under Group: Integration with SuccessFactors Employee Central, you will see that the scoping question "You can integrate your solution with SuccessFactors Employee Central" is unchecked.
- Expand Integration of Master Data.
- Under Group: Group: Employee Data, you will see that the scoping question "Do you want to replicate employee data from an external application to your cloud solution?" is unchecked.
- Try to confirm the changes and you will see the error message.
Cause
The reason why you are seeing this error is because there is a check implemented to maintain consistency between SuccessFactors and Business ByDesign. Descoping will not be allowed if you have successful replication requests between these two systems.
Resolution
The best way to restore the system to the pre-integration state is to create a service request from the Service Control Center Work Center to restore the system to its previous restoration point, when the integration was not scoped.
You can check if there is an active restoration point created in the Service Control Center Work Center, because it is only possible to rollback the tenant to a restore point if it is created accordingly.
Also, it is possible to terminate the tenant and request a new tenant from Service Control Center Work Center, if it is a test tenant.
See Also
2560598 - How to Request Restore/Rollback to Restore Point?
2798983 - How to check if the restore point exists for a tenant
Keywords
integration with successfactors, descope, integration of employee data from external application to cloud solution, employee central , KBA , integration with successfactors , descope , employee central , external application , AP-HMD-RPL , HCM-Master Data Replication , How To