SAP Knowledge Base Article - Public

2980982 - DRTM Error in Manage Data "Country/Region period value must be greater than 0"

Symptom

When trying to set a DRTM for a specific country, you are receiving the error message "Country/Region period value must be greater than 0"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Admin Center > Manage Data > DRTM Master Data > USER > Take Action > Make Correction > Add Country, timeUnit
  2. Set the inactive period as 0
  3. The below message is shown:

Cause

It is an expected behavior and for some DRTM is needed to set the inactive period greater than 0.

Resolution

If you need to purge data without DRTM, you can use the DRM feature and mark the option "Ignore data retention time configuration for this purge request":

  1. Navigate to Admin Tools -> Data Retention Management ->  Create New Purge Request
  2. Select DRTM Master Data Purge
  3. Search for a specific User or Select Upload a list of inactive users only (by User ID or Assignment ID)
  4. Mark the option "Ignore data retention time configuration for this purge request"
  5. Upload the file according to the template
  6. Select the approvers
  7. Submit the request
  8. Approve/Decline Request

Please notice that the option "Ignore data retention time configuration for this purge request" is only available to purge Individual users through searching for each user or importing CSV with all users.

See Also

KBA 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users

Keywords

purge, DRTM, Master data, pop up, , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors HXM Suite 2005

Attachments

Pasted image.png
Pasted image.png