Symptom
In Global Application Settings > Mail tab, email addresses are set up as to what administrators see as the sender in Admin Email Notification and what the learners see as the sender in User Email Notification. However, there are business scenarios wherein administrators need to change it from test@abc.com to Company ABC<test@abc.com>. But upon clicking Apply Changes button, the error message "The administrator email is invalid." is displayed.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to System Administration > Configuration > Global Application Settings > Mail tab
- Set the value of Admin Email Notification or User Email Notification to Company ABC<test@abc.com>
- Click Apply Changes
Cause
There is a configuration in LMS_ADMIN namely emailValidationEnabled that when set to true, will perform validation checks moving forward if an update of value in all email address fields is a valid email address. Otherwise, it will throw an error message.
Resolution
- Navigate to System Administration > Configuration > System Configuration
- Edit the LMS_ADMIN configuration
- Set the emailValidationEnabled to false
- Click Apply Changes
- Navigate to System Administration > Configuration > Global Application Settings > Mail tab
- Set the value of Admin Email Notification or User Email Notification to Company ABC<test@abc.com>
- Click Apply Changes
- Go back to LMS_ADMIN configuration (see Step 1)
- Set the emailValidationEnabled back to true
- Click Apply Changes
See Also
Keywords
the administrator email is invalid., admin email notification, user email notification, update, change, admin, user, email, notification, error, invalid, emailValidationEnabled, global application settings, configuration, mail , KBA , LOD-SF-LMS-NOT , Notifications , Problem