SAP Knowledge Base Article - Public

2981323 - Extensibility for service : missing "Adapt UI" option - SAP S/4HANA Cloud Public Edition

Symptom

The option "Adapt UI" is not available in Edit Mode for Service Orders, Service Contracts, or Solution Orders.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  • Create a new custom field using the "Custom Fields and Logic" app.
  • Enable the field for service orders or service contracts.
  • Save and publish.
  • Go to Edit Service Order, Edit Service Contract, or Edit Solution Order: The option "Adapt UI" is not available in the object page toolbar.

Cause

There can be two different reasons for this behavior:

  1. System role: It’s not possible to adapt the UI in a production system
  2. Authorizations: It’s not authorized to use the extensibility features provided in Service in SAP S/4HANA Cloud Public Edition

Resolution

If the system is a production system, check the KBA 2885507 Missing "Adapt UI" option.

Regarding the authorities of the key user, SAP Fiori catalog role Extensibility - Service SAP_S4CRM_BC_ADMIN_EXT_PC must be added in its profile. Read help documentation "Extensibility for Specific Service Apps".

See Also

Help Portal: Extensibility for Specific Service Apps

Keywords

Custom Fields, Extensibility, UI Option, Adapt UI, Service Order, Service Contract, Solution Order, SAP_S4CRM_BC_ADMIN_EXT_PC, business catalog, authorities, authorization, access, production, service apps  , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , CRM-S4-SOL-SLO , S4CRM: Solution Order , How To

Product

SAP S/4HANA Cloud Public Edition all versions