Symptom
The option "Adapt UI" is not available in Edit Mode for Service Orders or Service Contracts.
Environment
S/4HANA Cloud Service
Reproducing the Issue
- Create a new custom field using the "Custom Fields and Logic" app.
- Enable the field for service orders or service contracts.
- Save and publish.
- Go to Edit Service Order or Edit Service Contract: The option "Adapt UI" is not available in the object page toolbar.
Cause
There can be two different reasons for this behavior:
- System role: It’s not possible to adapt the UI in a production system
- Authorizations: You aren’t authorized to use the extensibility features provided in Service in SAP S/4HANA Cloud
Resolution
If the system is a production system, please check the KBA 2885507 Missing "Adapt UI" option .
Regarding the authorities of the key user, SAP Fiori catalog role Extensibility - Service SAP_S4CRM_BC_ADMIN_EXT_PC must be added in its profile. Read help documentation "Extensibility for Specific Service Apps".
See Also
Keywords
Custom Fields and Logic, Extensibility, UI Option , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , CRM-S4-SRV-CTR , S4CRM: Service Contract , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , How To