Symptom
You notice that Workflow Rules of type Messaging are failing with the error message Business configuration not found (TYPE_CODE=2049). Please contact your administrator.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Service work center.
- Navigate to Tickets work center view.
- Open any ticket.
- Navigate to Workflow Changes tab.
- See the failed workflow log and the error message.
Cause
Workflow Rules of type messaging will fail with the above error when the messaging activity is not scoped in the system.
Resolution
- Navigate to Business Configuration work center.
- Navigate to Implementation Projects work center view.
- Click Edit Project Scope.
- Navigate to step 4 Questions.
- Expand Sales.
- Expand Account and Activity Management.
- Select Activity Management.
- Check the question Do you want to record messaging activity?.
- Save the changes.
Keywords
Workflow, Workflow Rule, Rule, Messaging Activity, Messaging, Message, SMS, Error Message, Failure, Failed, Tickets, Sales, Service, Account and Activity Management, Do you want to record messaging activity?, Business configuration not found (TYPE_CODE=2049). Please contact your administrator, , KBA , LOD-CRM-SC-MES , Messaging / SMS , How To