Symptom
Refresh action will reset all filters in SAP Analytics Cloud mobile app
Environment
- SAP Analytics Cloud (Enterprise)
- SAP Analytics Cloud mobile app
Reproducing the Issue
- Log on to SAC tenant.
- Create a new story and add a Responsive Page.
- Add one chart/table based on sample model [BestRunJuice_SampleModel].
- Add multiple story filters or page filters on any dimension.
- Save the story.
- Log on to same tenant from SAC mobile app and then open the story.
- Try to change selection in those filters.
=> The chart/table will shown data according to the selected range by filters. - Click Refresh in the context menu in SAC mobile app.
=> The selection in those filters will be reset to the value(s) saved in step 5.
Cause
- It is by-design.
- Refresh action will reset all filters, which are changed when viewing the story in SAP Analytics Cloud mobile app.
- It is different from the behavior of Refresh button in menu of story when it is opened in browser. Instead, the refresh button in SAC mobile app works as "Reload" like using browser refresh button.
Resolution
- Change individual filter to other values instead of using Refresh button if you don't want to reset all filters.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-MOB , SAC Mobile , Problem