SAP Knowledge Base Article - Public

2981933 - KUT Fields from Employee Time Sheet do not Appear for Service Agents

Symptom

After adding extension fields to the employee time sheet (in Time Administration - Time Sheet), the same fields are not available in the adaptation mode of the service agents time sheet (in Service Agents - Edit Time Sheet).

Environment

  • SAP Business ByDesign 

Reproducing the Issue

You have created some extension fields through adaption mode on "Time Administration - Time Sheet" for employee time entries. You want the same set of extension fields on "Project Management - Service Agents" for service agents.

Cause

The fields added to the employee time sheet are only available for internal employees. The view in Service agents work center currently does not allow the addition of extension fields. The same constraint applies to the Employee self-service (ESS) Time sheet.

Service Agent shares the Employee Business Object Instance, that will have an indicator as External.

Resolution

The system works as expected.

Keywords

Timesheet, KUT, Service Agent, Time Sheet, Employee, Time Administration. , KBA , SRD-HR-TLM , Time and Labour Management , How To

Product

SAP Business ByDesign all versions