Symptom
When trying to create a new E-Mail Template in the Content view of the Sales Campaign work centre, you receive the error: "Please upload a content. Save Failed."
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales Campaigns work centre.
- Go to the Content view.
- Click New -> E-Mail Template.
- Enter the mandatory and necessary information as per your requirement.
- Save and open.
- In the Details facet of the Content object, enter all mandatory data.
- Under 'Languages' click 'Add'.
- Enter Language and Subject.
- Upload your saved template.
Result: Error "Please upload a content."
Cause
The html template was saved without UTF-8 encoding. Templates saved with a different encoding result in upload errors, such as this.
Note: you can see that the File Name is not getting filled when you use an un-encoded template.
Resolution
Save HTML templates with UTF-8 encoding.
- Paste your template into a Notepad/ Notepad++
- Tab Encoding -> select Convert to UTF-8
- Save/ Save as html
- Retry the same steps as previously in the system, but this time upload the newly saved template.
See Also
Keywords
KBA , LOD-CRM-MKT-CAM , Campaigns , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions