SAP Knowledge Base Article - Public

2982305 - An Error on Adding the Internal Notes in a Closed Ticket

Symptom

An error Changing TEXT-CONTENT not possible; field is read-only is trigger in closed ticket on adding an internal comment.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Search and open ticket LMN (where LMN represent the ticket id with status closed).
  4. Click on an edit button and go to the Notes facet.
  5. Add an internal comment and click on save button.
  6. An error Changing TEXT-CONTENT not possible; field is read-only is trigger.

Cause

Though the internal comment is editable it is not possible to add it in closed ticket.

Resolution

Internal notes cannot be added to closed tickets, and hence you see an error in the UI after trying to add a note to the ticket is an expected system behavior.

Keywords

Notes facet , Closed ticket , KBA , text-content , internal comment , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions