Symptom
You are using ManageSalesOrderIn webservice to create a Sales Order, but you are facing an error: Bank account does not exist, in the Response.
Environment
SAP Business ByDesign
Reproducing the Issue
You send your request via Soap UI or any other system, and you get the following error:
- Bank account does not exist.
Cause
Look specifically under the <PAYMENT_CONTROL> tag, you will see several tags maintained that are not present in your payload.
The most important tag here is: <PaymentProcessingCompanyID></PaymentProcessingCompanyID>.
Without this ID, the UUID of the bank account cannot be determined.
Resolution
Once the <PaymentProcessingCompanyID></PaymentProcessingCompanyID> is provided, the error is not raised.
Keywords
Sales Orders; Payment; Bank Account; , KBA , SRD-CRM-ORD , Orders & Contracts , How To