Symptom
You have installed and configured Cloud Print Manager (CPM) at your server or computer to "Save to File" instead of printing in a regular printer. However you noticed that just some prints are saved in the folder you have configured.
Also, some prints are appearing as Failed in CPM queue and when looking for print queues in ByDesign front-end you can see different filepaths:
Saved to directory C:\Users\YourUser\YourFolder
Saved to directory C:\Users\DifferentUser\DifferentFolder
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
- SAP Cloud Print Manager
Cause
This is caused because the CPM is running in a different user or computer with same logon settings.
Resolution
The best approach is to ask your IT team to identify the user or computer under the wrong filepath "C:\Users\DifferentUser\DifferentFolder" and uninstall CPM from it.
If you are unable to identify the different user you can change the PRT user used in the print queues or create a new one. With this change the other user/computer will not be able to authenticate anymore.
To create a new user:
- Go to Application and User Management workcenter.
- Go to Print Queues.
- Select the desired print queue.
- Click at Edit button.
- Go to Details tab.
- At Assigned User field you can click at New.
- Set the password and save clicking at OK button.
After this you will need to set the new user in CPM:
- Open Cloud Print Manager
- Select the system in the list and edit it with right click of the mouse.
- Change the PRT user and password.
- Save.
- CPM services will restart and connect with new user.
Keywords
cloud print manager, CPM, print queue, save to file, different locations, different folders , KBA , AP-RC-OUT , Output Management , How To