SAP Knowledge Base Article - Public

2985074 - "Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [field1, field2,]. Ensure these fields are mapped only in one entity in admin tools" - Recruiting Management

Symptom

When initiating onboarding from an application for a candidate, the following message appears: "Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [field1, field2,]. Ensure these fields are mapped only in one entity in admin tools".

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

  1. Open a Job Requisition;
  2. Find a candidate that is on the correct status and qualifies for Onboarding;
  3. Attempt to initiate onboarding;
  4. Error appears "Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [field1, field2,]. Ensure these fields are mapped only in one entity in admin tools".

Cause

This is caused by the changes on the Setup Onboarding 1.0 Integration page.

  • The Onboarding fields are mapped in more than one Recruiting entities (Job Requisition / Job Application / Job Offer).
  • Changes on the page are not synced to the mapping templates in Provisioning.

Resolution

This happens when the system is looking at the mapping and finding multiple values being mapped to the same field, and it can happen even sometimes when you don't have multiple fields in recruiting being mapped to the same one in Onboarding.

To resolve this, do the following:

  1. At first, execute an OData Metadata Refresh. Check article 2171588 for the steps;
  2. Now, access Setup Onboarding 1.0 Integration page;
  3. In there you will have tabs for Job Requisition, Job Application and Offer;
  4. Review the three of them and all templates you have to confirm that you have this mapping happening in only one of the three. Meaning, the field can only be mapped from Job Requisition, Job Application or Job Offer, otherwise the system will have a conflicting mapping. This error usually is generated on the field that has a blue asterisk, focus on these first.

IMPORTANT REMINDERS:

  1. In case all of them are already correct, there are two ways to force an update on the mapping of the fields and make the Initiate Onboarding to start working again.
    1. Access Setup Onboarding 1.0 Integration page;
    2. Go to the other two entities that shouldn't have the field mapped;
    3. Change the mapping of the field from "No Selection" to something else;
    4. Back to "No Selection" and Save it.

          Alternatively, for those who have provisioning access:

    1. Go to Provisioning > Import Export for RCM templates Mapping;
    2. Go to the other two entities that shouldn't have the field mapped;
    3. Export the XML templates;
    4. Remove the mapping of the field from those templates;
    5. Import the templates.
  1. The error message will show the Field ID that is being mapped more than once, which sometimes could have a different label.

See Also

2171588 - OData API Metadata Refresh and Export - SuccessFactors Cloud

Keywords

error, onboarding, initiate, conflict, mapping, process, not, able, continue, proceed, multiple, fields, unable , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions ; SAP SuccessFactors Recruiting all versions