Symptom
The country in the compliant address is not visible in the data export of letter campaigns if the account is in the US
Environment
SAP Business ByDesign
Reproducing the Issue
Go to the Marketing work center.
Select the Campaigns view.
Open the Campaign ABC (ABC represents the name of the campaign).
Click on the Restore export File button.
Open the excel sheet:
The compliant address does not include the country if the country is US.
Cause
For a postal address the "COUNTRY" field is only available, if the target address is located in a different country than the sending address.
For addressing Campaigns, the country of the user processing the campaigns is used as the sending country.
In your example of Campaign ABC, the user that created the campaign has either
- the address in the US or
- the user has no Country maintained in the workplace address at all.
If 1 is the case: for all accounts in the US, the address is formatted as a domestic address, and the "COUNTRY" is not included in the address.
If 2 is the case: If no Country of the user is maintained the system has a fall back logic that uses the country US and hence US is not printed.
Resolution
In case the user is not located in the US, the user needs to maintain the correct data in the workplace address.
Keywords
compliant; Address; Country; missing , KBA , AP-CPG-CPG , Campaign , Problem