Symptom
- Some picklists are sorting alphabetically despite specifically configure as custom.
- Month picklist is not sorting accordingly based Sort Order (L Value).
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Go to Picklist Center
- Select Picklist ID
- Adjust Display Order to Custom
- Set L Value to the picklist
- When checking the actual field with picklist, it displays alphabetical instead of the custom configuration.
Cause
The inconsistency is caused by MDF Cache or Picklist Cache that is stored on data center level.
Resolution
Inconsistency on data usually happens in MDF Based objects. If there are changes made that does not reflect the instance or career site, this can be fixed clearing the MDF Cache.
Please follow the solution in this KB article:
2534674 - How to fix inconsistencies in MDF Objects List?
If you have already done MDF Cache several times but the issue still exists, do a refresh of the Picklist Cache by referring to the following KBA:
2909168 - Picklists showing numbers and inconsistent after a refresh or disaster recovered restore
See Also
2848565 - MDF Picklist - How to control the Display order?
2534674 - How to fix inconsistencies in MDF Objects List?
2909168 - Picklists showing numbers and inconsistent after a refresh or disaster recovered restore
Keywords
Not Arranged, Different, Order, Incorrect, Sorting, Picklist, Center, Refresh, MDF, Object, List , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-OBD , Onboarding , LOD-SF-MDF-PKL , Picklists , Problem