Symptom
When opening a Sales Order in the system the error message "Vertex Error: SOAP:1,044 SRT: Consumer is temporarily isolated.No processing is allowed" is displayed in the UI.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Orders Work Center
- Go to the Sales Orders View.
- Filter for All Orders.
- Select the Sales Order ABC (ABC represents the Sales Order ID).
- Open, Select View All.
The error message "Vertex Error: SOAP:1,044 SRT: Consumer is temporarily isolated.No processing is allowed" is displayed in the UI.
Cause
When communication arrangements are copied from Productive systems they are set to "Isolation", which is to make sure that Test system of ByD do not communicate to a productive third party system (for example if outbound deliveries are set up in third party then both Test and Productive now will have same communication arrangements and start communicating to a productive third party system).
When communication arrangements are copied API keys are also cleared.
Resolution
You should be able to clear this scenario from your side by following these steps:
- Go to the Application and User Management workcenter.
- Open the Communication Arrangements view.
- Find Communication Arrangement "Request tax rates from Vertex" and Highlight it.
- Click the "Edit API Keys".
- Click again "Edit API Keys" in the following screen to input the expected value.
- Select Save button.
- Find Communication Arrangement "Request tax rates from Vertex" and Highlight it.
- Click the "De-Isolate" button (A Reactivate might be necessary).
Keywords
service temporarily unavailable; vertex error, no processing is allowed, communication arrangement, sales order, isolation, consumer is temporarily isolated , KBA , SRD-CRM-ORD , Orders & Contracts , How To