SAP Knowledge Base Article - Public

2987488 - Unable to Decline e-Signature - Onboarding

Symptom

Unable to decline e-signature and move candidate back to Personal Data Collection step.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login as an onboardee
  2. Click on complete e-signature tile
  3. Click on decline e-signature
  4. After declining it, the candidate should be moved back to personal data collection step.

Cause

This is due to the size of fields 'declineDocuments' and 'declinedReasons'.

Resolution

Following are the steps to resolve it: 

  1. Go to Admin center -> Configure object definition
  2. Search for 'Object Definition' of object 'Document Flow'
  3. Take action -> Make correction
  4. Click on details for the field 'declinedDocuments'
  5. Update filed 'Maximum Length' from 255 to 1000.
  6. Do the same for field 'declinedReason'
  7. Save object definition and try again the decline flow.

Keywords

locked, Decline, declined, esignature, signature, e-signature, provide, personal, data, trigger, again, twice, pdc, Onboarding, OBX , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Problem

Product

SAP SuccessFactors Onboarding all versions