Symptom
There are instances where some transformation rules are not taking effect when Item Connector runs. For example, even after adding the transformation rule item.field.transform.data.SUBJ_AREA_1.GEN_TOP="General Topic" to convert the label "General Topic" into the LMS Subject Area ID of "GEN_TOP", the Item Connector will still display an exception of Entity does not exist.SubjectAreaID: General Topic.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to References > Learning Activities > Categories
- Click Add New
- Set the Category ID field with value GEN_TOP
- Set the Description field with value General Topic
- Click Add
- Navigate to System Administration > Configuration > System Configuration > Connectors
- Add below property:
- item.field.transform.data.SUBJ_AREA_1.GEN_TOP="General Topic"
- Click Apply Changes
- In the existing item_data input file, add the header SUBJ_AREA_1 with value of General Topic
- Place the input file in the SFTP server
- Navigate to System Administration > Connectors > Item Connector
- Schedule the Item Connector to run
- After the connector execution, click View Results > Exceptions
Cause
The transformation rule for Item Connector is not enabled.
Resolution
- Navigate to System Administration > Configuration > System Configuration > Connectors
- Add below property:
- item.connector.input.file.field.transformation.enable=true
- Click Apply Changes
Note: Transformation rule won't work with NULL (N/A) value.
Keywords
item connector, transformation, transformation not working, transformation rule not working, item, connector, rule, learning, lms, entity does not exist, configuration , KBA , LOD-SF-LMS-CON , Connectors , Problem