SAP Knowledge Base Article - Public

2988270 - Is It Possible to Extend PDI Fields into the Customer Merge Work Center?

Symptom

You want to know if it is possible to work with PDI fields in the Customer Merge work center.

Environment

SAP Cloud for Customer 2008 and higher.

Reproducing the Issue

  1. Go to the Customer Merge work center.
  2. Click Create button.
  3. Maintain the required fields.
  4. Click Save and Open.
  5. In the Customer Merge screen the PDI field is not available there.

Cause

When creating a Customer Merge the coding checks the metadata of the COMMON (‘general’ section) and ADDRESS_INFORMATION (‘Address’ section) node for extension fields.
For each field found that way, if the content differs between the surviving record and the duplicates – and only if that is the case - that field is added to the ‘Attribute Selection’ tab where the user can select which value to keep in the surviving record.

The extension fields maintained at extensible nodes that are related to the business partner in a 1:n cardinality – like BUSINESS_PARTNER_RELATIONSHIP ROOT (‘Relationship’ section) are copied/moved together with the corresponding instance.

Resolution

Currently it is the expected system behavior.

Keywords

PDI Field, Customer Merge, Not Appearing, Does not appear, not visible. , KBA , LOD-LE-BP-BP , Business Partner , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions