SAP Knowledge Base Article - Public

2988309 - Service Ticket Opening in Edit Mode

Symptom

You would like to understand the reason on why tickets are opening in edit mode.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Service work center.
  2. Navigate to Tickets work center view.
  3. Select and open any ticket.
  4. See the ticket opens in edit mode.

Cause

This behavior happens when there is a modify action getting triggered from UI in the Business Object.

Resolution

This is achieved when the agent adds an Embedded Component (EC) in the UI and set the flag Work Protect Relevant as True for a field, under Data model and Properties.

When the EC is added, if there are any data defaulting operations performed during the load of EC, it will cause a modify on the Business Object, making the ticket opening in edit mode.

Keywords

Ticket, Service, C4C, Cloud for Customer, Open, Edit, Edit Mode, Opening, Service Ticket Opening in Edit Mode, Items; PDI; inport event CreateInstance; Facet; Root; Always; Editable , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions