Symptom
You have noticed that an employee is able to post a new leave request even when the balance of the respective quota account is less than zero (negative).
Environment
SAP Business ByDesign
Reproducing the Issue
To check the negative quota of the time account:
- Go to the Time Administration Work Center.
- Go to the Employees view.
- Search for the desired employee and click Edit.
- Go to the Time Account Balances tab.
- You see that for your time account for vacation, the balance is negative; however, it is still possible to post new leave requests under Employee Self-Services.
Cause
In the fine-tuning activity "Time Accounts - ABC" (where ABC stands for the affect employee's actual country/region of employment), you see that for the relevant vacation time account type, the Check Limit and Minimum Balance Limit are not maintained.
Resolution
To correct this, please follow the steps below:
- Go to the Business Configuration Work Center.
- Go to the Overview view.
- Search for the fine-tuning activity "Time Accounts - ABC."
- Click the link to Maintain Time Account Types.
- Select the relevant time account type for vacation.
- Edit the Check Limit and Minimum Balance Limit as desired.
Note: maintaining Check Limit option as Fixed Limit, but not defining a Minimum Balance Limit will still allow posting beyond zero, since the system will not know at which point to limit further postings.
See Also
Configuration: Maintain Time Account Types in SAP Help Portal.
Keywords
leave request, vacation, time account, negative balance, negative quota, check limit , KBA , leave request , time account , negative balance , negative quota , SRD-HR-TLM , Time and Labour Management , How To