Symptom
- Candidate was successfully initiated Onboarding from RCM but does not show up in Onboarding Dashboard.
- In Business Process error tile, one of the following error messages is available:
- An error occurred while saving the HRIS data for the user <NewHireName> due to the following reason: {"responsePayload":[{"userSysId":"XYZ","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Invalid Country: US in entity: homeAddress for UserId: XYZ"}]}]}.
- An error occurred while saving the HRIS data for the user <NewHireName> due to the following reason: {"responsePayload":[{"userSysId":"XYZ","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Invalid Country: in entity: homeAddress for UserId: XYZ"}]}]}.
Environment
SAP SuccessFactors Onboarding 2.0
Reproducing the Issue
- Initiate Onboarding from RCM
- Go to Onboarding Dashboard (candidate is not visible)
- Go to Business Process tile
- Open the error message
Cause
- Wrong values being sent from RCM OR inactive/non-existant records for country in Manage Data > Country / Region.
- The field that is mapped to homeAddress field in "Recruit-to-Hire Data Mapping" is empty on RCM side
Resolution
For Cause 1:
- Manage Data > Country/Region
- Open Country in question
- Ensure country is active and that same country code is being sent from RCM.
For Cause 2:
- Recruit-to-Hire Data Mapping
- Check what RCM field is mapped to EC "country" field
- Ensure this field is updated on RCM side e.g. if the country field from application template is mapped then ensure this country field has a value on the candidate's application
Keywords
homeaddres, invalid, country, onboarding, 2.0, rcm, integration, initiate, onboarding , KBA , LOD-SF-OBX , Onboarding 2.0 , LOD-SF-OBX-RCM , Initiate onboarding from RCM , LOD-SF-RCM-ONB , Onboarding integration , Problem
Product
SAP SuccessFactors Onboarding all versions