SAP Knowledge Base Article - Public

2991607 - HomeAddress issue while initiating Onboarding - Onboarding 2.0

Symptom

You have successfully initiated Onboarding from RCM, however, your new hire does not show up in Onboarding Dashboard. When you to Business Process error tile, the following error message is available:

An error occurred while saving the HRIS data for the user <NewHireName> Swensrude due to the following reason: {"responsePayload":[{"userSysId":"128","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Invalid Country: US in entity: homeAddress for UserId: 128"}]}]}.

Environment

SAP Successfactors Onboarding 2.0

Reproducing the Issue

  1. Initiate Onboarding from RCM;
  2. Go to Onboarding Dashboard (candidate is not visible);
  3. Go to Business Process tile;
  4. Open the error message

Cause

This issue can be caused by wrong values being sent from RCM OR inactive/inexisting records for country in Manage Data > Country / Region.

Resolution

Make sure that you have the country as active under Manage Data > Country and the same country code is being sent from RCM.

Keywords

homeaddres, invalid, country, onboarding, 2.0, rcm, integration, initiate, onboarding , KBA , LOD-SF-OBX , Onboarding 2.0 , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors Onboarding all versions