SAP Knowledge Base Article - Public

2991830 - Requestor Notification Message Missing After Processor Approve JEs

Symptom

When the parked journal entries are approved, Requestors can see that there are messages in their Notification Icon on top right corner, however no messages related when they click the Notification Icon.

Environment

SAP S/4HANA Cloud 2008 or Above

Reproducing the Issue

1. Use the submitter role to open 'Verify General Journal Entries' app, submit a Journal Entry e.g. 100001402.
2. Go to approver role, there is a new notification 'General journal entry 100001402 is waiting for approval.', and go into the inbox app. Then approve it.
3. Go to submitter role, there is a new notification message in Notification Icon on top right corner, however no messages related when open it.

Cause

The texts of the notification have been enhanced since CE2011. From technical view, if the Notification Metadata for existing Notification is changed, it is necessary to clear the cache or delete the notifications from both Q and P system. Otherwise the new metadata (text/parameter) will not be available for business users. So the notification doesn’t work.

Resolution

SAP cannot centrally clear the notification for all S/4HANA Cloud customers because customers are using many type of notification like Business Workflow, Purchase Order, Accounting, Situations….Centrally clearing the notifications means - schedule a job in all S/4 HANA Cloud system to clear all those notifications which will severely impact other applications and customers.

Please note, in order to fix this issue, we can only clear the notification cache for the customer who are effected based upon their request and permission. In other words, it means we need customer approval to delete all the notifications which you can see when click the bell at the top right in your system. Once the cleanup is done, not only journal entry notifications are cleared, but many types of notification like Business Workflow, Purchase Order, Accounting, Situations….

So for S/4HANA Cloud customers who are affected by the Journal Entry notification issue, please raise an case under component FI-FIO-GL-TRA for both your Q and P system, and request to clear notification cache. In the meanwhile, please also give SAP your permission to clear all the notifications in your Q and P system, so that SAP can proceed and delete them.

After that, the issue can be fixed.

Keywords

Verify General Journal Entries, F2547, Verify Journal Entries in General Ledger - For Processor (Inbox), F2728, requester, notification, message, blank, CE2011, CE2008 , KBA , FI-FIO-GL-TRA , Transaction Apps , FI-FIO-GL-TRA-2CL , Transaction Apps (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions