Symptom
Candidate Status counting inside the Job Requisition is not reflecting number of candidates in Talent Pipeline
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Login into customers instance
- Go to Recruiting and Select Job Requisition
- Candidates not counted in Talent pipeline
Cause
The cause of this issue is related to the Auto Data Purge feature on Preview instances. The Application Status Audit Trail and other audit information is purged by the system automatically and this has interfered with the calculation of candidate count on the job requisitions.
For more information on the Auto Purge feature, please see the following guide.
Resolution
Our engineering team have created a temporary solution where the Application Status Audit Trail and other audit information will be retained in the system for up to one year and will not be purged until the retention period has elapsed. This is a temporary preventative measure which will stop the issue from reoccurring, however it is important to note that the audit information that is already purged is not recoverable and is lost. This temporary fix will be applied in the B2105 Release. Please note that until the preview release occurs, you may still see issues regarding incorrect candidate count.
The Release Dates for B2105 is as follows:
Preview: 16th April 2021
The engineering team have also planned for a more permanent fix which include a redesign of how the candidate count is calculated and will avoid using audit information that is currently being purged by the auto purge feature. The engineering team are prioritizing this fix and it is planned for B2111 Release. Please be aware that this is a target date and not a commitment.
See Also
Keywords
Talent Pipeline, Canidate Zero, Wrong number of Candidates, purge, audit, RCM-86708 , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem