SAP Knowledge Base Article - Public

2992318 - Wrong User Details are Shown in a SuccessFactors Extended Cloud Foundry Application

Symptom

After logging out of a SuccessFactors extended Cloud foundry application and logging in again with a different user, the old user details are still shown.

Environment

SAP Cloud Platform Cloud Foundry

Reproducing the Issue

  1. Log into the extended application with user A.
  2. User A's details are shown.
  3. Log out and login with user B.
  4. User A's details are still shown.

Cause

  • The browser is blocking the third party cookies which breaks the IdP initiated logout from the SuccessFactors.
  • The browser has changed the default value of the cookie attribute “SameSite” 

Resolution


- Make sure that third party cookies are enabled in the browser.

  Note: if incognito window is used in Chrome, by default third party cookies are blocked.

- Set the attribute SameSite=None for the session cookie. It can be done by configuring the COOKIES environment variable as described at Additional cookies.

Keywords

SF, extension, logout, login , KBA , BC-NEO-EXT-SF , Extensibility of SAP SuccessFactors on SAP CP , Problem

Product

SAP SuccessFactors HXM Core 2005