SAP Knowledge Base Article - Public

2993217 - Recruiting email is not received - Recruiting Management

Symptom

Recruiting Email triggers and application status emails are not being sent to the candidates.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Go to career site
  2. Create an account
  3. Once created, try to reset the password of the account

Cause

In 2005 release, SAP SuccessFactors enabled “Envelope Sender DNS Verification” feature (aka sender domain check) on all its mail servers.

The purpose of this feature is to improve security by preventing any email notification whose Sender is not a valid email address to be sent from the system.

Meaning that for all our customers any mail whose domain does not exist or the email is not valid, it will not be accepted and processed by our mail servers.

Resolution

The common cause of the issue is appending location/country in the email domain like @us.sap.com. You can use DNS CHECK to validate if domain is valid.

To correct the issue, go to Manage Recruiting Settings > Return Email Address Information. Update the "Return address for system-generated emails to candidates" with valid email domain.

See Also

2939495 - Email Notifications are NOT received - Single Sender Enable

Keywords

email not sent delivered, interview email, acknowledgement email, reject rejection disqualification , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions