SAP Knowledge Base Article - Public

2993636 - Error with Data Sequence - Imported GUIDs Validity (Check ID: JDMImportedGUIDInvalid or JPBImportedGUIDInvalid) - Job Description Manager and Job Profile Builder

Symptom

  • When running the checks for Job Description Manager application in Admin Center > Check Tool, issue(s) for the check "JDMImportedGUIDInvalid" can be found
  • When running the checks for Job Profile Builder application in Admin Center > Check Tool, issue(s) for the check "JPBImportedGUIDInvalid" can be found.

Environment

  • SAP SuccessFactors Job Description Manager
  • SAP SuccessFactors Job Profile Builder

Reproducing the Issue

This results from issues managing Families and Roles in JDM or creating new Objects for JPB (Families, Roles, Competencies, Behaviors, Job profiles, or any job profile sections) under Manage Job Profile Content, Manage Job Profile Templates, Manage Job Profiles or via Import.

Cause

GUIDS have manually been created which causes the IDs to be out of sequence

Resolution

Sequence is a unique ID that defines the GUID for any newly created fields for JDM and JPB in database, and it works as an incremental list, which is shared by most of the JDM and JPB fields. This means that when creating a Family the system assigns GUID '10" to it. Creating a new Role after that, the system will use GUID "11" if no other data has been created in between.

If we create data via import, this same behavior will apply. However, it is possible to manually assign a GUID to newly created data, and if it hasn't been used already, system will allow the data to be created under the GUID that manually set in the import file, instead of getting it from the sequence number list.

However, once you create more and more data, via UI or import, the sequence number will be increased, and once it gets to a value that was already manually set to a field, it will not be able to proceed, and thus it will not allow you to create any new objects. 

Prerequisite

Some checks have a Quick Fix, which can be used to immediately correct any issues found by that check. Users with permission "Allow Check Tool Quick Fix" granted in RBP can click the results and will see the four-step process at the top of the Detailed Results dialog.

Resolution Steps:

  1. Complete all four steps to fix the sequence issue, providing your approval for the data selected, and click Close to complete the process. Procedure can be found in the Using the Quick Fix Feature section of the Check Tool Guide.
  2. Once completed, the check for Data Sequence Issue will run again to verify if the fix was completed successfully.

Prevention:

To avoid this type of issue, whenever you are creating new data for JDM or JPB via import make sure to leave the GUID column blank.

NOTE: For objects only being edited via import, keep the same system-generated GUID in the file.

Still Need Help?

If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.

See Also

Keywords

JPB Sequence, Sequence Job profile, cannot create JPB Objects, Job Profile Check Tool, Save JPB Data, Add Job Profile Data, error when saving new Family Role Job Code Competency, JDM, JDMv1.0, JDMv1, Families & Roles, check tools, PTCH-36455, JDMImportedGUIDInvalid , KBA , LOD-SF-TIH-JPB-MIG , Migration to Job Profile Builder , LOD-SF-TIH-JDM , Job Description Manager , Problem

Product

SAP SuccessFactors HCM suite all versions