Symptom
You are facing a dump in the user inteface (UI) when trying to edit a communication arrangement which has been created for a communication scenario within an Add-on in the Cloud Applications Studio.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- In Cloud for Customer:
- Go to Administration work center.
- Open General Settings view.
- Click on Communication Arrangements.
- Edit the affected artifact.
- In Business ByDesign:
- Go to Application and User Management work center.
- Click on Communication Arrangements.
- Edit the affected artifact.
Cause
This exception (dump) occurs if any service is unselected from a communication scenario definition and the same is not updated in the communication arrangement.
Resolution
Whenever a service is added or removed from the communication scenario after the communication arrangement is created, the communication arrangement must be deleted and re-created to get the latest changes.
Keywords
error, PDI, .CSD, SDK , KBA , AP-RC-BDS-WS , ByDesign Studio Web Services , AP-RC-CEC-B2B , ByD On-Demand Cloud-Process Integration B2B , How To